NumPy 1.16.0 是最后一个支持 Python 2.7 的版本

NumPy 项目在 2017 年宣布将停止支持 2。现在它发布了最后一个支持 2.7 的版本 1.16.0,它将一直支持到 2020 年。NumPy 1.16.0 支持 Python 2.7 和 3.5-3.7,不再支持 3.4。主要新变化包括:实验性支持 overriding numpy 函数,matmul 成为通用函数,改进 和 POWER 架构支持,改进 AIX 和 PyPy 支持,改进 ctypes 的互操作,改进 PEP 3118 支持,等等。NumPy 以后发布的版本将只支持 Python 3。

标签:, ,